Laboratoire Microsoft |  CertifExpress 
 Le Forum de Réfèrence sur les Technologies Microsoft - http://www.forum-microsoft.org

MDT: Problème mise a jour drivers WinPE TOPIC_SOLVED

Forum dédié aux méthodes de déploiement des OS Microsoft comme Microsoft Deployment toolkit par exemple (MDT2010/MDT2008/BDD/OSD/WDS/WAIK)

Modérateurs : Modérateurs, Modérateurs_Systèmes

MDT: Problème mise a jour drivers WinPE  TOPIC_SOLVED

Message par Scoot » Jeu 18 Août 2016, 17:13

Bonjour

J'ai farfouillé sur le net mais je ne trouve pas de réponse concernant mon problème

Sur un MDT avec ADK monté sur un Win 2008r2 je tente de mettre a jour le package de pilote HP V5.0.

Si l'ajout des pilotes dans le répertoire WinPE 32b se passe bien, l'update du déploiement ne se fait pas correctement

J'obtiens une erreur pour chaque nouveau pilote:


There was a problem opening the INF file. C:\Déploiements\Deploy7\Out-of-box Drivers\Net\E1D6232_12.13.17.7_31B6643E7BB7AD7AE972FC2251D1928D6E1DF6B5\E1D6232.INF Error: 0x80070002. 

Erreur�: 2 

No driver packages were found on the specified path.

Verify that the driver .INF files are in the specified location and try the command again. 

Le fichier journal DISM se trouve � l'emplacement C:\Windows\Logs\DISM\dism.log 

Exit code = 2 

DISM /Add-Driver failed, rc = 2.

Injected driver Intel Net E1D6232.INF 12.13.17.7

 

Et ce type de message pour chaque drivers (il y en a une dizaine). Il va de soi que le répertoire en question contient bien les fichiers demandés.

J'ai augmenté le scratch space à 128 au cas où mais cela ne change rien. J'ai supprimé tous les pilotes winPE 32b pour ne remettre que ceux téléchargés, pas mieux.

Alors forcément, le WinPE généré ne contient pas les pilotes nécessaires aux déploiements et je me retrouve avec le message d'erreur sur le pilotes avant d'arriver au type de déploiement.

Quelqu'un aurait il une petite idée qui me permettrait d'avancer?

En vous remerciant par avance

Je rajoute un extrait du log DISM suite à mon dernier essai :

2016-08-18 16:13:52, Error DISM DISM Driver Manager: PID=3600 TID=2360 Error, file not found 'C:\D+�ploiements\Deploy7\Out-of-box Drivers\Net\E1D6232_12.13.17.7_31B6643E7BB7AD7AE972FC2251D1928D6E1DF6B5\E1D6232.INF'. - CDriverManager::OpenPackageByFile(hr:0x80070002)
2016-08-18 16:13:52, Error DISM DISM Driver Manager: PID=3600 TID=2360 Errors were found opening driver package C:\D+�ploiements\Deploy7\Out-of-box Drivers\Net\E1D6232_12.13.17.7_31B6643E7BB7AD7AE972FC2251D1928D6E1DF6B5\E1D6232.INF. - CDriverManager::Internal_DoAddDriverPackage(hr:0x80070002)
2016-08-18 16:13:52, Error DISM DISM Driver Manager: PID=3600 TID=2360 base\ntsetup\opktools\dism\providers\dmiprovider\dll\drivermanager.cpp:1075 - CDriverManager::Internal_DoAddDriverPackage(hr:0x80070002)
2016-08-18 16:13:52, Error DISM DISM Driver Manager: PID=3600 TID=2360 base\ntsetup\opktools\dism\providers\dmiprovider\dll\drivermanager.cpp:523 - CDriverManager::ExecuteCmdLine(hr:0x80070002)

Si ca parle à quelqu'un...

Scoot
Scoot
N00b
N00b
 
Message(s) : 2
Inscription : Jeu 18 Août 2016, 17:10

Re: MDT: Problème mise a jour drivers WinPE

Message par Scoot » Ven 19 Août 2016, 15:04

J'ai trouvé la réponse (un peu aidé)

Le dossier en question est créé par MDT lors de l'import des drivers, que ce soit pour les drivers WinPE ou les drivers du profil matériel. Le message d'erreur ci dessus provient de la tentative d'intégration de ces drivers dans l'iso WinPE

Par acquis de conscience, j'ai copié collé le chemin indiqué dans l'explorateur windows ce qui m'a amené directement au répertoire contenant 8 fichiers dont les inf sys et cat habituel.

Par contre j'ai du modifier le D+�ploiements en déploiements pour y accéder ce qui m'a amené a me demander si cela ne bloquait pas aussi l'import. J'ai donc modifié mon deployement share et viré le é du nom du répertoire

Mise à jour des drivers WinPE et update du deploiement... et plus d'erreur :)



Il fallait deviner que MDT était capable d'écrire dans un répertoire mais pas capable de lire les accents quand il importe des fichiers de ces même répertoires (un sous process qui ne gère pas les accent sans doute ? )


Ne pas oublier de repartager le répertoire du deploiement



Scoot
Scoot
N00b
N00b
 
Message(s) : 2
Inscription : Jeu 18 Août 2016, 17:10


Retour vers Déploiement des systèmes d'exploitations Windows

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 9 invité(s)



Accueil | News | Articles | Tips | Outils | Certification | Easters Eggs
Essentiels | Glossaire | Vidos | Whitepapers | Essentiels | Bote Scripts
Conditions d'utilisation & Copyright | Respect de la vie prive