Laboratoire Microsoft |  CertifExpress 
 Le Forum de Réfèrence sur les Technologies Microsoft - http://www.forum-microsoft.org

TMG2010 :: Publication SharePoint 2010

Un forum dédié au serveur firewall/proxy de Microsoft

Modérateurs : Thierry DEMAN (MVP Exchan, alex117, ygainche, Modérateurs, Modérateurs_Applicatifs

TMG2010 :: Publication SharePoint 2010

Message par marcowz » Mar 06 Sep 2011, 10:33

Bonjour à tous,

Je viens ici car je rencontre actuellement quelques problématiques lors de la publication de mon portail collaboratif SharePoint 2010 avec TMG 2010.

Voici mon Infra :

- un serveur SharePoint 2010 avec une application Web
(Mes mappages de substitutions : URL par défaut : http://nom_du_serveur et URL interne entreprise : http://intranet.monentreprise.com et URL externe entreprise : https://extranet.monentreprise.com)
- un serveur de base de donnés
- un serveur ForeFront TMG 2010 (en DMZ)

J'ai configurer le port d'écoute du TMG sur le port 443 (avec un certificat public). Ma publication fonctionne, j'arrive donc dans un premier temps sur l'interface de connexion de TMG, puis après authentification (j'utilise le cookie TMG) j'arrive sur mon SharePoint. Jusqu'ici aucun problèmes.

Mes problèmes sont les suivants :
- Lors de la fermeture d'un document Office Web App en externe, une traduction de lien s'effectue mal et je suis rediriger vers URL par défaut : http://nom_du_serveur au lieu de https://extranet.monentreprise.com
- Lors que l'on veut effectuer une connexion Outlook d'une liste en externe, même problème la traduction de lien s'effectue mal et elle veut se connecter à l'URL par défaut : http://nom_du_serveur au lieu de https://extranet.monentreprise.com

J'ai tester sans publication TMG, tout fonctionne bien, le problème vient donc de la publication TMG mais après avoir tester pas mal de choses, je viens ici pour voir si quelqu'un à déjà eu et corriger ce problème.

Merci d'avance
marcowz
N00b
N00b
 
Message(s) : 1
Inscription : Jeu 29 Juil 2010, 17:23

Re: Publication SharePoint 2010 avec TMG 2010 SP1

Message par alex117 » Sam 16 Juin 2012, 20:01

Bonjour,

Ton message a été déplacé, car la question n'était pas posée au bon endroit. Tu étais dans le forum Forefront for Exchange/SharePoint, or ta question porte sur Forefront TMG 2010. Oui je sais, c'est très compliqué les gammes de produit chez Microsoft :)

Personnellement, je pense que c'est plutôt liée à un problème AAM de ton SharePoint.
Déjà comme ton site est en https d'un point de vue publique, il faut tout de même rajouter le http dans ton AAM extranet, en gros avoir les deux.
Exemple ci-dessous :
Image

Ensuite, est-ce que le listener de ton TMG est en https only ? Si oui, tu peux alors ajouter une redirection automatique du flux http vers SSL

Dernier point, si TMG bloque ou interprète peut-être pas correctement comme tu le suspectes, il faut faire une journalisation en live lors de cette tentative. Si rien d'anormal coté TMG, une trace réseau de type Fiddler permettra de voir quelle tentative d'url est effectuée lors de ton erreur.

Deux articles sur TMG et SharePoint que j'ai rédigé, qui pourrait t'aider :
http://www.alexgiraud.net/blog/Lists/Billets/Post.aspx?ID=117
http://www.alexgiraud.net/blog/Lists/Billets/Post.aspx?ID=118

Alex
Cordialement,
Alex117 - Giraud Alexandre
3SR Solutions de Sécurité Systèmes et Réseaux
MVP Forefront / Enterprise Security
Modérateur du forum Forefront Laboratoire Microsoft Supinfo
http://www.alexgiraud.net/blog
Avatar de l’utilisateur
alex117
Grand Master Flash
Grand Master Flash
 
Message(s) : 2186
Inscription : Sam 04 Fév 2006, 10:33
Localisation : Bordeaux - Paris - Bordeaux - Paris ... bon par là :) !

Re: Publication SharePoint 2010 avec TMG 2010 SP1

Message par alex117 » Sam 16 Juin 2012, 20:02

Rhoooo (3ème fois ce soir :))
Je viens de déterrer un vieux post du 06 Septembre 2011, ...
je sors :arrow:
Cordialement,
Alex117 - Giraud Alexandre
3SR Solutions de Sécurité Systèmes et Réseaux
MVP Forefront / Enterprise Security
Modérateur du forum Forefront Laboratoire Microsoft Supinfo
http://www.alexgiraud.net/blog
Avatar de l’utilisateur
alex117
Grand Master Flash
Grand Master Flash
 
Message(s) : 2186
Inscription : Sam 04 Fév 2006, 10:33
Localisation : Bordeaux - Paris - Bordeaux - Paris ... bon par là :) !


Retour vers Forefront TMG/ISA Server

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 9 invité(s)



Accueil | News | Articles | Tips | Outils | Certification | Easters Eggs
Essentiels | Glossaire | Vidos | Whitepapers | Essentiels | Bote Scripts
Conditions d'utilisation & Copyright | Respect de la vie prive